Wednesday, February 24, 2010

v.1.0.0.3 - eTVnet.ca plugin - Vista support is here!

Due to a few clever tricks, I was able to sneak in Vista support into the plug-in.  Only limitation in Vista: no on-screen keyboard during search.

Enjoy!

6 comments:

Alexandre said...

Спасибо за работу.
Выглядит очень обещающе.
Попытка установить на Win7-Ultimate/32 не сложилась:
install прошел гладко, но в Extra фолдере MCE ничего не появилось. Также не оказалось xml файла в \Windows\ehome.
В Control Panel\Programs тоже вроде ничего нового.
Ранее у меня стоял plug-in EtvViewer.

Саша

Igor Papirov said...

Poprobuyte prosto vistavit' s .msi file, a ne cherez install.cmd
Dayte znat' esli budet rabotat'?

Alexandre said...

Thank you, Igor.
As you suggested, run .msi-file instead of .cmd works flawless.
Your plug-in is awesome: professional design, intuitive UI etc. Thank you!
So far, I've found the only bug: "play" button does not work in folder "Избранное".
One suggestion: what if click on record will immediately play it, but if you choose "Info" button on remote it goes to current "info and play" page.
Once again, thank you very much for you awesome work.

Alex

Igor Papirov said...

Alexandre,

Chto vy imeete v vidu chto Play ne rabotaet v folder Izbrannoe? Vy pitayest' nazhat' na ">" Play knopky kogda naxodites' v Izbrannom ili vy zaxodite v konkretnoe video, i nazhimaete tam knopochku "Prosmotr" no on ne pokazivaet?

Esli pervoe, to da, k sozhaleniyu ya ne nashel kak eto mozhno sdelat' poka. Esli vtoroe, i u vas kakie-to video ne igrayut, skazhite pozhaluysta kakie (konkretno, dazhe dayte URL na nix)... ya proveryu chto i kak.

Naschet "info" button, k sozhaleniyu tut nichego nelzya sdelat', Microsoft specialno ne dal programmistam dopuska k etomu buttonu. Ya by tozhe xotel by chtoby Video Info tolko vyxodilo kogda nazhimaetsa knopka (I)nfo. Uvy.

Alexandre said...

Я имел кнопку "Просмотр" в режиме "Избранное". Нажатие на эту кнопку не ведет к просмотру программы для любой программы из этого фолдера (у меня их 2 десятка). Я подозреваю, что вы испольуете тот же темплейт для всех фолдеров, так что возможно для этой папки URL на программу формируется неверно(?), а прерывание замаскировано try/catch обработчиком (?). Как получить URLы из-под MCE без отладчика я не знаю.

Igor Papirov said...

Если возможно, пожалуйста отправте мне что вы видите если введете этот линк:
http://www.etvnet.ca/cgi-bin/video/eitv_browse.fcgi?action=favorites&skin=XML
(до этого надо залогинится в сайт). Можете из XML-а вытащить ваш логин. Пошлите пожалуста XML на igor<_at_>parusoft.com

Вы правы, код у меня тот же самый который проигрывает все видео подряд, но XML на узбранное иной чем который на "browsing" и там может быть какой-нидь другой формат который у меня не показывает.

Спасибо,
Игорь